Results 1 to 3 of 3

Thread: Tech help.

  1. Default Tech help.

    Found my old iPod in the press.still like new. But when I go to download apps they require ios 7/8 or higher. Mine is ios6.1.6 and reads up to date . Is it time to buy a new one or can it be updated further.

  2. #2
    Join Date
    Apr 2016


    iPhones and pods can only be updated to a certain point based on their model. If you've got an old one they eventually stop releasing updates and you have to either deal with a loss of functionality or buy a newer one.

  3. The Following User Says Thank You to ClarkKent For This Useful Post:

    Coupleup4fun (01-06-16)

  4. Default

    Kinda thought that but never mind. Can go back in the press.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts